关于Apache Tapestry反序列化漏洞的预警提示

发布时间:2021-07-05 16:29阅读:10

一、漏洞详情

Apache Tapestry是美国阿帕奇(Apache)基金会的一款使用Java语言编写的Web应用程序框架。

Apache Tapestry 4版本存在反序列化漏洞,该漏洞源于在调用页面的验证方法之前尝试反序列化“sp”参数,攻击者可利用该漏洞导致未经身份验证的反序列化。

建议受影响用户及时更新漏洞补丁进行防护,做好资产自查以及预防工作,以免遭受黑客攻击。

二、影响范围

Apache Tapestry 4

三、修复建议

厂商已发布了漏洞修复程序,请及时关注更新:https://lists.apache.org/thread.html/r700a6aa234dbff0555d4187bdc8274d7e4c0afbf35b9a3457f09ee76@%3Cusers.tapestry.apache.org%3E